Community Health Network Walgreen's timeslots not showing on web pages.

Incident Report for Community Health Network

Resolved

Incident is resolved; timeslots are now appearing on webpages
Posted Aug 11, 2023 - 10:58 CDT

Investigating

We are investigating an issues where CHN Walgreen's timeslots are not showing on web pages.
Posted Aug 08, 2023 - 13:10 CDT
This incident affected: CHN Same-Day Care (Retail).